• Domingo 23 de Enero de 2022, 03:01

Autor Tema:  Problema Al Iniciar El Device  (Leído 1594 veces)

andresca

  • Nuevo Miembro
  • *
  • Mensajes: 24
    • Ver Perfil
Problema Al Iniciar El Device
« en: Miércoles 27 de Febrero de 2008, 23:23 »
0
Hola a todos....

Estoy iniciando Direct3D en C# pero a la hora de probar el programa que sale una excepcion "InvalidCallExcepcion" y "Error in the application", el problema esta cuando se crea el device, todos los parametros que ingrezan al contructor de la clase Device estan correctos, pero mi objeto device queda como null, no se que me puede estar causando este problema, he reinstalado todo desde el visual C# express, pasando por el service pack y el framework 3.5 hasta el directX version agosto 2007 varias veces y nada de nada me sigue saliendo el mismo error.

ayudaaaaa....

saludos...
Andres Camilo

razago

  • Nuevo Miembro
  • *
  • Mensajes: 3
    • Ver Perfil
Re: Problema Al Iniciar El Device
« Respuesta #1 en: Lunes 18 de Mayo de 2009, 23:23 »
0
Ese error me ha dado cuando los parametros del device son incorrectos para crearse, repasalos
        With PresentParam
            .EnableAutoDepthStencil = True
            .AutoDepthStencilFormat = Microsoft.DirectX.Direct3D.DepthFormat.D16
            .BackBufferFormat = Microsoft.DirectX.Direct3D.Format.A8R8G8B8
            .BackBufferCount = 1
            .BackBufferWidth = 1280
            .BackBufferHeight = 800
            .Windowed = True
            .PresentationInterval = Microsoft.DirectX.Direct3D.PresentInterval.Default
            .SwapEffect = Microsoft.DirectX.Direct3D.SwapEffect.Flip
        End With
        Device = New Microsoft.DirectX.Direct3D.Device(0, Microsoft.DirectX.Direct3D.DeviceType.Hardware, Me.PictureBox1, Microsoft.DirectX.Direct3D.CreateFlags.SoftwareVertexProcessing, PresentParam)