• Viernes 14 de Mayo de 2021, 09:42

Autor Tema:  Problema Con Ois  (Leído 2111 veces)

Huevo

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Problema Con Ois
« en: Viernes 7 de Diciembre de 2007, 22:25 »
0
Tengo un problema, estoy siguiendo un tutorial para aprender ha usar los listeners para las acciones al presionar un boton o hacer click....

me dicen que haga una variable *mKeyboard, pero no me dan el tipo de variable y hay es donde me da el error ...

en otro tutorial encontre que es IOS::Keyboard *mKeyboard

(OIS::Keyboard), es el tipo y tengo que importar #include <OIS/OIS.h>, para que sirva pero no encuentra esta libreria...

que puedo hacer???

Los tutoriales son estan en ogre3d.com/wiki/index.php/Basic_Tutorial_4.html

Angel38

  • Miembro MUY activo
  • ***
  • Mensajes: 370
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #1 en: Sábado 8 de Diciembre de 2007, 19:27 »
0
Tienes que mirar si es la version nueva de Ogre, pues a este se le han modificado algunos codigos de la anterior version.

De todas formas voy a investigar para si te puedo ayudar, aunque mi compañero Steel X creo que tiene más conocimiento, le diré que lea tu post.
[size=109]Se me olvidó instalar los Drivers de Cordura en mi Cerebro.

Huevo

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #2 en: Sábado 8 de Diciembre de 2007, 22:32 »
0
Tengo la version 1.2.4 del SDK del ogre eso es todo lo que puedo decir

SteelX

  • Miembro MUY activo
  • ***
  • Mensajes: 218
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #3 en: Domingo 9 de Diciembre de 2007, 14:40 »
0
Estas Usando la versión de Ogre conocida cómo dagon, lo mas probable es que el tutorial que estés siguiendo sea el de eihort que es la versión 1.4x de ogre.

Revisa los paths de los includes de Ogre a ver si se encuentra ese directorio que estás necesitando. En mi caso:

C:\OgreSDK\include

dentro de include esta otro directorio llamado OIS, y el archivo .h se encuentra dentro de este.


cualquier cosa estaré pendiente, para ayudar.

 :hola:
Inside the code

Angel38

  • Miembro MUY activo
  • ***
  • Mensajes: 370
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #4 en: Lunes 10 de Diciembre de 2007, 15:26 »
0
Ha el problema es que estas usando una version ya desactualizada de Ogre.

Te recomiendo que vayas a la pagina de Ogre y descargues la version actual pues en las nuevas versiones siempre hay reparaciones de errores.
[size=109]Se me olvidó instalar los Drivers de Cordura en mi Cerebro.

Huevo

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #5 en: Lunes 10 de Diciembre de 2007, 22:03 »
0
Cita de: "SteelX"

Revisa los paths de los includes de Ogre a ver si se encuentra ese directorio que estás necesitando. En mi caso:

C:\OgreSDK\include

dentro de include esta otro directorio llamado OIS, y el archivo .h se encuentra dentro de este.


cualquier cosa estaré pendiente, para ayudar.

 :hola:
Dentro de la carpeta C:\OGRESDK\include tengo otras 3 carpetas, pero ninguna de esa es OIS, o contiene a OIS.h, que puedo hacer ....?

No se pueden pasar y copiar esa carpeta en la direccion correspondiente?, o tengo realmente que actualizarme a una nueva version de Ogre

ProfesorX

  • Moderador
  • ******
  • Mensajes: 796
  • Nacionalidad: mx
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #6 en: Lunes 10 de Diciembre de 2007, 23:58 »
0
Ay huevo, ya te dijeron que para los tutoriales, necesitas la nueva version de OGRE 1.4.x (van dos veces que te lo dicen), ya no pierdas el tiempo preguntando y bajatela, de todas formas la necesitaras ;)

Saludos :)

NOTA:
==================================================================
Este foro es para ayudar, aprender, compartir... usenlo para eso,
NO SE RESUELVEN DUDAS POR MENSAJE PRIVADO Y MENOS POR CORREO
==================================================================

Huevo

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #7 en: Martes 11 de Diciembre de 2007, 22:37 »
0
Sera actualizarme ...

Gracias ....

 :alien:  :comp:

Huevo

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Re: Problema Con Ois
« Respuesta #8 en: Martes 18 de Diciembre de 2007, 06:04 »
0
Ya me baje e instale la nueva version de Ogre SDK 1.4.5, y ahora si veo que ya existen la carpeta OIS y el archivo OIS.h y el resto de cosas antes preguntadas....

Pero ahora, tengo otro problema y es que cuando compilo o construyo me tira 4 errores, bueno la verdad son del mismo tipo
Aqui se los dejo
------------------------------------------------------------------

1>Prueba.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: static class OIS::InputManager * __cdecl OIS::InputManager::createInputSystem(class std::multimap<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> >,class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> >,struct std::less<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > >,class std::allocator<struct std::pair<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > const ,class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > > > > &)" (__imp_?createInputSystem@InputManager@OIS@@SAPAV12@AAV?$multimap@V?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@V12@U?$less@V?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@@2@V?$allocator@U?$pair@$$CBV?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@V12@@std@@@2@@std@@@Z) referenced in function "public: __thiscall ExampleFrameListener::ExampleFrameListener(class Ogre::RenderWindow *,class Ogre::Camera *,bool,bool,bool)" (??0ExampleFrameListener@@QAE@PAVRenderWindow@Ogre@@PAVCamera@2@_N22@Z)


1>Prueba.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: struct OIS::MouseState const & __thiscall OIS::Mouse::getMouseState(void)const " (__imp_?getMouseState@Mouse@OIS@@QBEABUMouseState@2@XZ) referenced in function "public: virtual void __thiscall ExampleFrameListener::windowResized(class Ogre::RenderWindow *)" (?windowResized@ExampleFrameListener@@UAEXPAVRenderWindow@Ogre@@@Z)

1>Prueba.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: static void __cdecl OIS::InputManager::destroyInputSystem(class OIS::InputManager *)" (__imp_?destroyInputSystem@InputManager@OIS@@SAXPAV12@@Z) referenced in function "public: virtual void __thiscall ExampleFrameListener::windowClosed(class Ogre::RenderWindow *)" (?windowClosed@ExampleFrameListener@@UAEXPAVRenderWindow@Ogre@@@Z)

1>Prueba.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: bool __thiscall OIS::MouseState::buttonDown(enum OIS::MouseButtonID)const " (__imp_?buttonDown@MouseState@OIS@@QBE_NW4MouseButtonID@2@@Z) referenced in function "public: bool __thiscall ExampleFrameListener::processUnbufferedMouseInput(struct Ogre::FrameEvent const &)" (?processUnbufferedMouseInput@ExampleFrameListener@@QAE_NABUFrameEvent@Ogre@@@Z)

1>bin\Debug\Prueba.exe : fatal error LNK1120: 4 unresolved
 externals

-----------------------------------------------------------------

Si alguien me pudiera ayudar a resolver este error con OIS, se lo agradeceria