• Martes 19 de Octubre de 2021, 00:33

Autor Tema:  Problemas Con Vectores En Modelsim  (Leído 4643 veces)

Paisano

  • Nuevo Miembro
  • *
  • Mensajes: 3
    • Ver Perfil
Problemas Con Vectores En Modelsim
« en: Jueves 10 de Marzo de 2005, 15:33 »
0
Hola a todos , tengo un problemilla con los vectores para ejecucion de un archivo ALU en modelsim, es el siguiente, en el tercer dato del select sale un error y no he podido descifrar como corregirlo, he cambiado varias veces los tiempo de ejecucion, y los datos, agregado y quitado estado pero no lo he podido corregir, si alguien sabe, me podria guiar por favor, que puedo hacer para solucionar este problema. Gracias.
El mensaje contiene 1 archivo adjunto. Debes ingresar o registrarte para poder verlo y descargarlo.

Platypus

  • Miembro activo
  • **
  • Mensajes: 63
    • Ver Perfil
Re: Problemas Con Vectores En Modelsim
« Respuesta #1 en: Viernes 11 de Marzo de 2005, 23:50 »
0
Hola Paisano  :hola:

le eche un vistazo a tu código y supongo que el error que te da el simulador es sobre límite maximo de iteraciones o algo así. Sustituye, en la lista sensible del process de ALU.vhd, la señal result por sel y prueba, ya me comentarás los resultados.

Un saludo.  :)

© Jonathan ©

  • Moderador
  • ******
  • Mensajes: 1671
  • Nacionalidad: ar
    • Ver Perfil
    • http://www.einstec.com.ar
Re: Problemas Con Vectores En Modelsim
« Respuesta #2 en: Sábado 12 de Marzo de 2005, 00:44 »
0
Yo intente simular para ver si podia ayudar pero me aparecia un error de archivo .scf o algo asi :( .. estoy usando el MAX PLUS II .. creo que lo voy a sacar porque no he logrado simular nada.. alguien me puede explicar los procesos a cumplir para hacer una simulacion?. Gracias
EINSTEC Tecnología «La única fuente del conocimiento es la experiencia.»

«Lo importante es no dejar de hacerse preguntas.»

Platypus

  • Miembro activo
  • **
  • Mensajes: 63
    • Ver Perfil
Re: Problemas Con Vectores En Modelsim
« Respuesta #3 en: Domingo 13 de Marzo de 2005, 20:12 »
0
Hola  :hola:

para realizar una simulación primero tienes que describir el diseño en VHDL por un lado y por otro describir el test bench con el que se probará el diseño (también en VHDL). Debes compilar primero el diseño y después el test bench puesto que este último tendrá una instanciación del diseño que has descrito en el primer archivo.

Una vez compilado ambos archivos y sin problemas simulas el testbench y seleccionas las señales que desees visualizar en el cronograma.

En el Post de Tutoriales y Notas en cuanto la tenga lista postearé un breve guía de lo que hay que hacer para realizar una simulación de un diseño muy sencillito utilizando Modelsim.

Un saludo.  :)

Paisano

  • Nuevo Miembro
  • *
  • Mensajes: 3
    • Ver Perfil
Re: Problemas Con Vectores En Modelsim
« Respuesta #4 en: Lunes 14 de Marzo de 2005, 18:13 »
0
:D  Hola a todos, Muchas gracias por su ayuda, ya solucione el problema, el error se hallaba en la tercer iteracion pues era necesario crear otra señal para hacer la operacion, GRACIAS

© Jonathan ©

  • Moderador
  • ******
  • Mensajes: 1671
  • Nacionalidad: ar
    • Ver Perfil
    • http://www.einstec.com.ar
Re: Problemas Con Vectores En Modelsim
« Respuesta #5 en: Martes 15 de Marzo de 2005, 23:15 »
0
Cita de: "Platypus"
Hola  :hola:

para realizar una simulación primero tienes que describir el diseño en VHDL por un lado y por otro describir el test bench con el que se probará el diseño (también en VHDL). Debes compilar primero el diseño y después el test bench puesto que este último tendrá una instanciación del diseño que has descrito en el primer archivo.

Una vez compilado ambos archivos y sin problemas simulas el testbench y seleccionas las señales que desees visualizar en el cronograma.

En el Post de Tutoriales y Notas en cuanto la tenga lista postearé un breve guía de lo que hay que hacer para realizar una simulación de un diseño muy sencillito utilizando Modelsim.

Un saludo.  :)
Ahora entendi perfecto, el test bench seria lo que genera los datos para probar cada funcion del programa VHDL, me costo entender eso :( .. ahora me cuesta programar el test bench.. estoy trabajando con un sumador, si surgen dudas aviso. Saludos
EINSTEC Tecnología «La única fuente del conocimiento es la experiencia.»

«Lo importante es no dejar de hacerse preguntas.»

Platypus

  • Miembro activo
  • **
  • Mensajes: 63
    • Ver Perfil
Re: Problemas Con Vectores En Modelsim
« Respuesta #6 en: Miércoles 16 de Marzo de 2005, 20:15 »
0
Hola © Jonathan ©  :hola:

finalmente he hecho una breve guía de los pasos a seguir para realizar una simulación funcional de un sencillo diseño. No se si finalmente desinstalarás el MAX PLUS II. Si te decides por el ModelSim puedes probar con el ejemplo de Tutoriales y Notas.

Espero tus comentarios o dudas.

Un saludo.  :)

© Jonathan ©

  • Moderador
  • ******
  • Mensajes: 1671
  • Nacionalidad: ar
    • Ver Perfil
    • http://www.einstec.com.ar
Re: Problemas Con Vectores En Modelsim
« Respuesta #7 en: Sábado 19 de Marzo de 2005, 09:30 »
0
Cita de: "Platypus"
Hola © Jonathan ©  :hola:

finalmente he hecho una breve guía de los pasos a seguir para realizar una simulación funcional de un sencillo diseño. No se si finalmente desinstalarás el MAX PLUS II. Si te decides por el ModelSim puedes probar con el ejemplo de Tutoriales y Notas.

Espero tus comentarios o dudas.

Un saludo.  :)
Un millon de Gracias Colega! ;)  .. instalare ModelSim intentando no quitar el Max Plus II aparte tambien intentare simular de alguna manera el ejemplo que otorgas pero utilizando el MaxPlusII y si lo logro posteo los pasos!.. Gracias por esta guia tan util!. Un Abrazo!!  :smartass:  :comp:
EINSTEC Tecnología «La única fuente del conocimiento es la experiencia.»

«Lo importante es no dejar de hacerse preguntas.»