• Jueves 5 de Diciembre de 2019, 21:23

Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Temas - LuisDa

Páginas: [1]
1
XML / CityGML Echadme una mano
« en: Domingo 5 de Abril de 2009, 20:15 »
Buenas:

Lo primero de todo, este mensaje va dirigido a quien conozca bien CityGML.

Mi proyecto fin de carrera consiste en generar automáticamente modelos 3D de carreteras, para lo cual tengo que hacer uso del estándar CityGML, basado en XML.

Ya he conseguido manipular alguna demo que contiene edificios, pero lo que me interesa es meter los siguientes elementos en la carretera: puentes (sé que actualmente CityGML no tiene definida una clase para los puentes, pero creo que podrían implementarse como edificios que tengan solamente dos paredes enfrentadas y el techo), semáforos, señales de tráfico y paneles de información de las autopistas.

He intentado meter un semáforo en algún modelo con el siguiente fragmento de código:

  <cityObjectMember>
    <CityFurniture>
      <class>1000</class>
      <function>1080</function>
      <lod2ImplicitRepresentation>
        <ImplicitGeometry>
          <mimeType>model/vrml</mimeType>
          <libraryObject>aqui_habia_un_enlace_que_este_foro_no_me_deja_poner</libraryObject>
          <referencePoint>
            <gml:Point>
              <gml:pos srsDimension="3">3603845.54 5793898.77 44.8</gml:pos>
            </gml:Point>
          </referencePoint>
        </ImplicitGeometry>
      </lod2ImplicitRepresentation>
    </CityFurniture>
  </cityObjectMember>
  <cityObjectMember>
    <CityFurniture>
      <class>1000</class>
      <function>1080</function>
      <lod2ImplicitRepresentation>
        <ImplicitGeometry>
          <mimeType>model/vrml</mimeType>
          <transformationMatrix> 0.866025 -0.5 0 0.5 0.5 0.866025 0 0.5 0 0 1 0 0 0 0 1 </transformationMatrix>
          <libraryObject>aqui_habia_un_enlace_que_este_foro_no_me_deja_poner</libraryObject>
          <referencePoint>
            <gml:Point>
              <gml:pos srsDimension="3">3603820.54 5793801.77 45.8</gml:pos>
            </gml:Point>
          </referencePoint>
        </ImplicitGeometry>
      </lod2ImplicitRepresentation>
    </CityFurniture>
  </cityObjectMember>
</CityModel>

Pero en ningún caso aparece semáforo alguno, o bien ni siquiera se visualiza el modelo 3D.

¿Alguna ayuda? Si la tenéis, mandadme un mail a la dirección ld1984ster(arroba)gmail(punto)com.

Gracias por adelantado.

2
Software / Problema con Wireshark
« en: Sábado 28 de Marzo de 2009, 12:46 »
Buenas:

Estoy haciendo unas pruebecillas con el Wireshark desde mi portátil (reconozco que no soy muy experto en manejar este analizador, pero ya lo he usado un poco).

A la hora de empezar a capturar, dado que tengo dos interfaces (LAN Ethernet y WiFi), me pregunta de cuál quiero capturar tráfico. Si elijo la LAN Ethernet, no hay ningún problema, pero si selecciono la WiFi (estando conectado), no me captura ningún paquete.

De hecho, he desconectado adrede el cable de red y dejado solamente la conexión WiFi para que todo el tráfico de Internet vaya por WiFi y, pese a que puedo enviar y recibir correo y ver páginas web sin problemas, no aparece ninguna trama (de hecho, he hecho un ping continuo a Google y hasta he abierto el Firefox con todas las pestañas que tenía guardadas, vamos, que por tráfico no será, desde luego).

Otra cosa que me sorprende es la siguiente: Si elijo las interfaces, me aparecen tanto la WiFi como la LAN con una IP no nula y estando el cable de red desconectado, pero si desconecto la WiFi, ésta sí me aparece con 0.0.0.0.

Concretamente, ahora mismo este mensaje lo he posteado a través de mi conexión WiFi (tengo aposta desconectado el cable de red), y además tengo dos ping continuos a google y a youtube, y ambos me responden (vamos, que sí que estoy metiéndole tráfico), además de que puedo ver páginas web (para más gracia, estoy cargando una página de Youtube). Pero en el Wireshark, el número de paquetes capturados es CERO PATATERO. Eso sí, si conecto el cable de red y selecciono como interfaz la LAN cableada, vaya si salen paquetes.

¿Alguien sabe cómo podría hacer que pudiera capturar también a través de la WiFi? ¿Tengo que configurar algo?

Gracias por adelantado.

3
Papelera / Algoritmo de conversión de coordenadas
« en: Domingo 15 de Marzo de 2009, 18:06 »
Buenas:

Para mi proyecto necesito encontrar una fórmula (o algoritmo) que convierta las coordenadas geográficas de un GPS en coordenadas UTM (que son las que reconoce CityGML). Sé que tengo que buscar en Google, pero si alguien me puede ahorrar tal trabajo, se lo agradezco (tengo muchas otras cosas que hacer).

Saludos, programadores.

4
C/C++ / Leer de un fichero y generar otro fichero
« en: Domingo 1 de Marzo de 2009, 01:45 »
Buenas:

Para mi PFC necesito, entre otras cosas, leer varios ficheros *.txt, procesar la información contenida en ellos y generar un fichero *.xml con los resultados escritos en lenguaje XML.

Ya he visto cómo leer ficheros, pero, ¿sabe alguien cómo puedo hacer para crear un fichero? Sé que está la función tmpfile, en la que puedo crear el fichero y luego no hacer la llamada a fclose, dejando así ese fichero temporal sin cerrar. Me interesa eso, más que nada la estructura básica de creación de ficheros (y, por supuesto, escritura en ellos), para, partiendo de la misma, generarme yo mi código.

¿Alguna sugerencia mejor?

Gracias de antemano.

5
Windows / Drivers gráfica
« en: Domingo 22 de Febrero de 2009, 02:51 »
Hola:

A ver, necesito actualizar los drivers de mi gráfica para poder ejecutar herramientas de visualización 3D (forma parte de mi PFC), mi tarjeta es la Mobile Intel® 965 Express Chipset Family (mi portátil, un Acer Aspire 5315, lo tengo desde junio de 2008). El problema era que el portátil venía con Vista, y, cómo no, le metí el XP a las tres semanas (el Vista era cada vez más una pesadilla), y la versión más reciente de esos drivers es la 7.15.10.1608 (la que tengo actualmente en mi portátil es la 7.14.10.1409, y la "más reciente" para XP es una más antigua que ésa, la 6.14.10.5029).

¿Alguna otra manera de actualizar los drivers para esa tarjeta gráfica? Claro, que no implique meter Vista de nuevo, porque no estoy por la labor (lo siento, es que el Vista va contra mis principios  B) ).

Saludos y gracias de antemano.

NOTA: Las herramientas que no me funcionan son LandXplorer y Aristoteles 3D (ambas me dicen que actualice mis drivers antes de cargar un fichero XML con la descripción del modelo 3D).

Páginas: [1]