• Miércoles 8 de Diciembre de 2021, 14:06

Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Mensajes - Dwarft

Páginas: [1]
1
Allegro / Re: Instalando Allegro
« en: Domingo 5 de Noviembre de 2006, 17:41 »
Qué significa esto ??
Código: Text
  1. process_begin C:\Proyectos\C,C++\process_begin CreateProcess(c:\djgpp\bin\sh.exe, c:/djgpp/bin/sh.exe -c "gcc.exe prueba_curso_main.o Prueba_curso_proyect_private.res -o \"Prueba_curso_proyect1.exe\" -L\"C:/Dev-Cpp/lib\" -mwindows -lalleg_s -lkernel32 -luser32 -lgdi32 -lcomdlg32 -lole32 -ldinput -lddraw -ldxguid -lwinmm -ldsound  ", ...) failed.
  2.  
Me sale en los mensajes de error al compilar un proyecto.

GRACIAS
Salu2 !
pd: esto ya es lo ultimo que os pregunto, sino, a ver si probando con otros paquetes etc...

2
Allegro / Re: Instalando Allegro
« en: Viernes 3 de Noviembre de 2006, 20:16 »
He creado un proyecto (porque lo otro era un codigo fuente simple). Le he dado a que cree una aplicacion de allegro estatica (no DLL, no se si sera mejor la dinamica pero bueno ya me direis). He compilado y me dice error 87, el parámetro no es correcto  :unsure:, he mirado en propiedades del proyecto a ver si linkaba bien o no, y he visto esto en linker:
Código: Text
  1. -lalleg_s -lkernel32 -luser32 -lgdi32 -lcomdlg32 -lole32 -ldinput -lddraw -ldxguid -lwinmm -ldsound
  2.  
o sea, que si linka con proyectos no? Y por que no rula :(? El código del programita que he compilado esta vez es el que te viene por defecto en la aplicación de allegro.

Salu2 !
MUCHAS GRACIAS  :whistling:

3
Allegro / Re: Instalando Allegro
« en: Jueves 2 de Noviembre de 2006, 15:15 »
Como este:  
 [Linker error] undefined reference to `set_gfx_mode'
Con todas las funciones de la libreria que uso en el codigo.
Código: Text
  1. #include <allegro.h>
  2. #include <conio.h>
  3.  
  4. main()
  5. { allegro_init();
  6.  
  7.   if(set_gfx_mode(GFX_SAFE,320,200,0,0)!=0)
  8.   { set_gfx_mode(GFX_TEXT,0,0,0,0);
  9.     allegro_message("Incapaz de iniciar modo grafico");
  10.     return 1;
  11.   }
  12.   line(screen,20,10,310,175,palette_color[15]);
  13.   getch();
  14. }
  15. END_OF_MAIN();
  16.  
Eso de comprobar si lo estoy enlazando correctamente no se exactamente a que te refieres, si es a que lo instalé a partir del Packman.exe del devcpp... Si lo hice.

Salu2 !
MUCHAS GRACIAS

P.D: No es por ser pesado, pero es que con este paquete hace un tiempo lo estuve usando, de todas formas, si con vuestra ayuda no puedo hacer nada, me descargaré todo desde donde me poneis y lo haré todo de nuevo.  :)

4
Allegro / Instalando Allegro
« en: Domingo 29 de Octubre de 2006, 13:33 »
Buenas !
Miren, he instalado devcpp4990.exe y el paquete allegro-4.1.16.env. Con esto ya deberían de funcionar las funciones de allegro, verdad ? Es que he probado un programita en C y funciona, y luego he probado otro programita intentando iniciar modo grafico con allegro, pero me dice que las funciones no estan declaradas :S.

Salu2 !
GRACIAS

Páginas: [1]