• Miércoles 20 de Octubre de 2021, 11:44

Autor Tema:  Cero En El Puerto Paralelo  (Leído 3097 veces)

betitono1

  • Miembro MUY activo
  • ***
  • Mensajes: 235
    • Ver Perfil
Cero En El Puerto Paralelo
« en: Domingo 2 de Mayo de 2004, 19:08 »
0
Hola que ta tengo un problema par aue el puerto paralelo detecte un cero, me hace la detección cuando cuando entra tierra  y no cuando entra cero volts.


Mis sensores  envian de 0 a 1.4 volts cuando estan desactivados y 5 volts cuando esta activo.

Como puedo hacer para que en lugar de 0 o 1,45 me envie tierra.


Gracias


Saludos

© Jonathan ©

  • Moderador
  • ******
  • Mensajes: 1671
  • Nacionalidad: ar
    • Ver Perfil
    • http://www.einstec.com.ar
Re: Cero En El Puerto Paralelo
« Respuesta #1 en: Lunes 3 de Mayo de 2004, 16:20 »
0
Hola, los sensores conectados al puerto paralelo, no trabajan con la misma masa que el conector LPT???... lo que debes hacer va dependiendo del tipo de sensor, si puedes juntar las masas, es decir, que el sensor trabaje con la misma que el conector, podrias solcionar tu problema, antes deberias ver si el sensor acepta esa conexion, porque si es de los sensores que trabajan enviado 5 V o 0 V pero aparte de la masa, no creo que se pueda hacer mucho. Dime, y vemos. Saludos :hola:
EINSTEC Tecnología «La única fuente del conocimiento es la experiencia.»

«Lo importante es no dejar de hacerse preguntas.»

betitono1

  • Miembro MUY activo
  • ***
  • Mensajes: 235
    • Ver Perfil
Re: Cero En El Puerto Paralelo
« Respuesta #2 en: Viernes 7 de Mayo de 2004, 00:28 »
0
Lo que para es que tengo un opto porqe mi circuito sensor trabaja con 12 volt, el opto es un 4n25 y del lado de los 5 volts, coloque un 7805 para convertir los 12 a 5 volts pero el detalle de este opto es que cuando la base la dejo sin ninguna conexión me funciona correctamente,  y cuando lo coloco a tierra no funciona, por eso lo deje sin conexión y creo que ese es el problema, pero me han dicho que con una resistencia de 10kios en la salida de los 5 volts que van al puerto y a su vez el otro lado de la resistencia a tierra, y si funciona correctamente, lo acabo de probar y el programa hace la detección correctamente.


Saludos

caalavse

  • Nuevo Miembro
  • *
  • Mensajes: 1
    • Ver Perfil
Re: Cero En El Puerto Paralelo
« Respuesta #3 en: Martes 6 de Noviembre de 2007, 04:43 »
0
Muy bueno lo que comenta con lo de las resistencias de 10 k, Estoy trabjando con un sistema domotico que tengo que realizar para la universidad y me veo en complicación cuando queria recibir la información por el puerto LPT.
Mi pregunta es que si me podria ayudar enviandome el circuito que empleaste para poder trabjar el opto, la verdad me urje tenelo. Agreadezco la colaboración. Muchas gracias

betitono1

  • Miembro MUY activo
  • ***
  • Mensajes: 235
    • Ver Perfil
Re: Cero En El Puerto Paralelo
« Respuesta #4 en: Domingo 11 de Noviembre de 2007, 03:18 »
0
solo revisa la configuracion de los pines del LPT1.