• Lunes 21 de Junio de 2021, 02:54

Autor Tema:  problemas con programa en .ASM  (Leído 1690 veces)

dagger

  • Nuevo Miembro
  • *
  • Mensajes: 5
    • Ver Perfil
problemas con programa en .ASM
« en: Viernes 14 de Enero de 2011, 17:14 »
0
Hola a todos.... :P hace un tiempo un amigo me realizo un programa para 16F628A ..esta en .ASM..para hoteleria..(control de puertas)
Funciona perfecto.....pero de la operatoria diaria..de la mecanica de trabajo  surje un inconveniente...
El que me realizo el programa no tiene tiempo disponible , asi que busco ayuda a ver si alguien dispone de un tiempito para dedicarle a modificarlo   B)  B)
Si alguien puede me lo hace saber y adjunto todo el proyecto
Para dar una idea de que sucede......
Este es un control de apertura y cierre de puertas....entra o sale un cliente....
El sistema tiene 4 leds que informan el estado de cada habitacion.
led verde....habitacion disponible
led azul...habitacion a cobrar
led rojo...habitacion ocupada
led amarillo..habitacion para  limpieza
mecanica de trabajo
Comienza con led verde.
entra cliente..abre puerta..se apaga led verde y titila led azul (puerta abierta ciclo de entrada)
entra,cierra puerta..led azul fijo..(habitacion a cobrar)
una vez cobrada el conserje aprieta un boton en su tablero y apaga led azul y prende led rojo...(habitacion cobrada y ocupada)
se retira cliente..abre puerta..se apaga led rojo y titila led amarillo...la camarera revisa y si esta todo bien informa al conserje que aprieta boton y deja al led amarillo fijo...(habitacion a limpiar)
una vez limpia el conserje vuelve a apretar un boton y apaga led amarillo y prende led verde..(habitacion lista)
Bueno todo esto ya esta instalado y funciona bien..pero de la operatoria diaria surje un error que da lugar a confusiones.....una vez que el conserje dejo en amarillo fijo,cuando la camarera limpia la habitacion abre la puerta para limpiar el acceso...eso hace que nuevamente titile el led amarillo...entonces el conserje no sabe si titila porque la mucama esta limpiando o porque salio un cliente..tienen que revisar las planillas..etc...y cuando hay mucho trabajo es terriblemente complicado...
La idea seria que "una vez que el sistema fue puesto en led amarillo fijo...no actue el sensor de puerta hasta tanto el conserje lo  cambie de amarillo fijo a verde y comience nuevamente otro ciclo.
A todo esto me olvide de informar que el sistema funciona con un solo cable..se habilita la salida SDA....repito todo esta funcionando y bien
yo hice una modificacion (con mis rudimentarios conocimientos)en el programa y funciona perfecto ...PERO......al bloquear el sensor de puertas cuando se pone en amarillo...se bloquean todos los sensores...no se porque...se supone que cada programa le corresponde solo a un PIC y no a otro...por eso hay que poner antes de ensamblar el numero de habitacion que corresponde.....
Bueno luego de todo este quilombo si alguie tiene un tiempito..le agradecere muchisimo.
saludos