• Lunes 16 de Septiembre de 2019, 17:05

Autor Tema:  Programa jsp en blanco y negro  (Leído 1229 veces)

bertamax

  • Nuevo Miembro
  • *
  • Mensajes: 22
    • Ver Perfil
Programa jsp en blanco y negro
« en: Domingo 18 de Julio de 2010, 15:14 »
0
¿Por qué está el siguiente programa en blanco y negro y no con los colorines apropiados del netbeans? ¿Hay algo erróneo?

<%@page contentType="text/html"%>
<%@page pageEncoding="UTF-8"%>
<%@page import="java.io.*,java.sql.*"%>
<%@page session="true" errorPage="Error.jsp"%>
<jsp:useBean id="miBean" scope="session" class="beanBalnearios.altbajamodver"/>

<html>
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
        <title>JSP Page</title>

    </head>
    <body bgcolor="#669933">
        <%@include file="cabeceras.html"%>
        <%int res;%>
        <form name="frmBaja" action="bajabalnearios.jsp" method="post">
            <center>Codigo usuario: <input type="text" name="codigo_usuario"><br>
            <br>
            <input type="submit" value="Baja"></center>
            <%if(request.getParameter("codigo_usuario")!=null){
                String dn=request.getParameter("codigo_usuario");
                String q="delete from usuarios where codigo_usuario="+dn;%>
                <%miBean.Conexion();
                res=miBean.Update(q);%>
                <br><br><br><br>
                <b><center>numero de usuarios eliminados <%=res%></center></b>
                <%miBean.Cierra();
            }%>
        </form>
    </body>
</html>

Al depurarlo no me aparece ningún error, pero al ejecutarlo me aparece el siguiente error:

java.sql.SQLException: [Microsoft][ODBC SQL Server Driver][SQL Server]El nombre de objeto 'usuarios' no es válido.
Traza error [Microsoft][ODBC SQL Server Driver][SQL Server]El nombre de objeto 'usuarios' no es válido.

Gracias y saludos

bertamax

  • Nuevo Miembro
  • *
  • Mensajes: 22
    • Ver Perfil
Re: Programa jsp en blanco y negro
« Respuesta #1 en: Domingo 18 de Julio de 2010, 21:00 »
0
Ya lo he solucionado; es que no había una correspondencia entre las tablas y el código.

Saludos