• Lunes 25 de Octubre de 2021, 03:44

Autor Tema:  problema con CG y GLEW  (Leído 1256 veces)

satmon

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
problema con CG y GLEW
« en: Viernes 4 de Junio de 2010, 04:13 »
0
estoy diseñando un motor para video juegos, anteriormente programaba solo con DirectX pero ahora lon hago con GLUT por ser multiplataforma, la cosa es que quiero hacer vertex skinning por hardware pues por software es muy lento.

los shaders los cargo con CG pero no puedo por mas que lo intento pasarle informacion de los vertices al shader  solo le puedo pasar informacion de coordenadas de textura, posicion y normal. parece no haber forma de pasarle datos como las tangentes, blendindices o blendweights como en directx.

no crean que no intente pasarlos como coordenadas de textura, lo hice y no obtube los resultados que queria.

miren este esquema en donde use la funcion  glMultiTexCoord3f para definir los colores de cada vertice:

s3.subirimagenes.com:81/otros/4602592puu.jpg

la malla solo tiene 12 vertices y se supone que le pase el color que le pase las caras que se intersecten en un vertice deberian tener el mismo color en ese vertice pues es el mismo vertice y el mismo color pero no es así.

como observan aquí:

s2.subirimagenes.com/imagen/4608621esquema.png



¿¿alquien sabe por que??!!!

satmon

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Re: problema con CG y GLEW
« Respuesta #1 en: Viernes 4 de Junio de 2010, 19:00 »
0
ya lo solucione, fue a causa del error mas estupido que he cometido en mi vida