• Sábado 24 de Octubre de 2020, 10:56

Autor Tema:  Problema al guardar nuevos campos  (Leído 1436 veces)

koke106

  • Nuevo Miembro
  • *
  • Mensajes: 6
    • Ver Perfil
Problema al guardar nuevos campos
« en: Lunes 26 de Abril de 2010, 09:49 »
0
Buenas expertos

Necesito una ayuda, e creado unos nuevos campos y los he introducido como siempre he hecho, nose cual es el problema pero en algun punto debo de estar fallando, ya que cuando cierro el programa y lo vuelvo a abrir pierdo los cambios, no guarda lo que he hecho....
Alguien me puede dar una pista??

Con todos los demas campos si se guardan, solo me pasa con los nuevos que he creado.

Muchas gracias...cualquier ayuda me valdra...

Un saludo.

F_Tanori

  • Moderador
  • ******
  • Mensajes: 1918
  • Nacionalidad: mx
    • Ver Perfil
    • http://www.ingenieria-soporte.com
Re: Problema al guardar nuevos campos
« Respuesta #1 en: Lunes 26 de Abril de 2010, 12:48 »
0
Aportas poca informacion.

Que version de PB usas?
en donde te pasa eso en una ventana, en una funcion, en un datawindow, en un objeto,en una estructura etc..

Detalla mas el problema.


Saludos



" ExIsTo y A vEcEs PiEnSo "

NOTA:
===========================================================================================================================
Este foro es para ayudar, aprender, compartir... usenlo para eso,
NO SE RESUELVEN DUDAS POR MENSAJE PRIVADO Y MENOS POR CORREO
===========================================================================================================================

koke106

  • Nuevo Miembro
  • *
  • Mensajes: 6
    • Ver Perfil
Re: Problema al guardar nuevos campos
« Respuesta #2 en: Lunes 26 de Abril de 2010, 13:50 »
0
Buenas, a ver..utilizo PB 7.0 5031.
Me pasa..te cuento, tengo una ventana donde selecciono un usuario y dentro de usuario en otra ventana introduzco datos le doy a guardar y sin problema pero cuando salgo de ese usuario y vuelvo a entrar todos los datos que habia metido se han perdido, aunque como ya te digo solo me pasa con los campos nuevos que he creado... con todos los demas si me funciona....

Parece como una funcion que tengo, wf_grabar no esta funcionando bien..me hace un update de toda la ventana pero no coge los nuevos campos que he creado...lo estoy mirando con la BD abierta a la vez y los demas campos si me los pone bien pero esos me los rellena con NULL....

Un saludo y gracias.

F_Tanori

  • Moderador
  • ******
  • Mensajes: 1918
  • Nacionalidad: mx
    • Ver Perfil
    • http://www.ingenieria-soporte.com
Re: Problema al guardar nuevos campos
« Respuesta #3 en: Lunes 26 de Abril de 2010, 14:40 »
0
Cita de: "koke106"
Buenas, a ver..utilizo PB 7.0 5031.
Me pasa..te cuento, tengo una ventana donde selecciono un usuario y dentro de usuario en otra ventana introduzco datos le doy a guardar y sin problema pero cuando salgo de ese usuario y vuelvo a entrar todos los datos que habia metido se han perdido, aunque como ya te digo solo me pasa con los campos nuevos que he creado... con todos los demas si me funciona....

Parece como una funcion que tengo, wf_grabar no esta funcionando bien..me hace un update de toda la ventana pero no coge los nuevos campos que he creado...lo estoy mirando con la BD abierta a la vez y los demas campos si me los pone bien pero esos me los rellena con NULL....

Un saludo y gracias.

Te refieres a que no guarda en la base de datos? o los cambios al codigo?
Si es en la base de datos y comentas que haces un update, lo haces con SQL Incrustado o a traves del metodo Update del DW?
Si es a traves del Update del DW entra en el diseno del mismo en RowsUpdate Propertis y selecciona los nuevos campos para que te los actualice.

Si es a traves de SQL Incrustado muestra tu codigo.

Saludos



" ExIsTo y A vEcEs PiEnSo "

NOTA:
===========================================================================================================================
Este foro es para ayudar, aprender, compartir... usenlo para eso,
NO SE RESUELVEN DUDAS POR MENSAJE PRIVADO Y MENOS POR CORREO
===========================================================================================================================

koke106

  • Nuevo Miembro
  • *
  • Mensajes: 6
    • Ver Perfil
Re: Problema al guardar nuevos campos
« Respuesta #4 en: Lunes 26 de Abril de 2010, 14:51 »
0
mil graciassssss!!!!!!!

era eso... que cabezaaaaaa jejeje ya lo tengo, muchisimas gracias de verdad!! un placer..

por cierto, e estado intentando invitarte al Yahoo Messenger y al MSN pero no puedo con tu direccion...si me la puedes dar te lo agradeceria.. Un saludo y muchisimas gracias.

F_Tanori

  • Moderador
  • ******
  • Mensajes: 1918
  • Nacionalidad: mx
    • Ver Perfil
    • http://www.ingenieria-soporte.com
Re: Problema al guardar nuevos campos
« Respuesta #5 en: Lunes 26 de Abril de 2010, 15:29 »
0
Vale :P

Saludos



" ExIsTo y A vEcEs PiEnSo "

NOTA:
===========================================================================================================================
Este foro es para ayudar, aprender, compartir... usenlo para eso,
NO SE RESUELVEN DUDAS POR MENSAJE PRIVADO Y MENOS POR CORREO
===========================================================================================================================