• Jueves 23 de Septiembre de 2021, 01:35

Autor Tema:  Tunneles SSH  (Leído 1961 veces)

diego.martinez

  • Miembro MUY activo
  • ***
  • Mensajes: 297
    • Ver Perfil
Tunneles SSH
« en: Miércoles 7 de Octubre de 2009, 20:15 »
0
Buenas:

Veamos, estoy intentando poner seguridad encripatada para las comunicaciones FTP y HTML  en un servidor interno de la empresa.

Para ello, me he instalado OpenSSH y lo he configurado con claves RSA.

Hasta aqui todo correcto.

Conecto al SSH con el Putty y todo va bien. Cuando no tenia la seguridad RSA puesta, me autentificaba y podia entrar en el arbol de directorios y todo.
He puesto seguridad y le he puesto la clave Id_Rsa que he creado con el OpenSSH (y modificado para usarla con el Putty usando el PuttyGen) y le incrusto la clave "putty" en Connection > SSH > Auth > Private Key... etc.

Cuando me conecto al Servidor SSH todo va bien, me solicita usuario , introduzco uno valido, me pide el Passphrase para la clave rsa (se lo facilito) y me autoriza y en ese momento hop: "Connection Closed by remote Host"

No se que puedo estar haciendo mal. La clave es valida, por que si suministro otra me dice "invalid passphrase" y me la pide otra vez. El usuario tambien es valido.

Que puede estar pasando?
tengo algo mal configurado? en el cliente o en el server?
es su forma de decirme que no vale la id_rsa que le he puesto al putty?

otra cosa, no se como mirar los logs del servidor (por si aparecia algo interesante) google dice que haga "ssh -vvv" o "ssh -v -v -v" pero eso no funciona y en la lista de parametros no aparece....

Otra cosa mas, cuando me autentificaba mediante user/pass todo iba bien. Pero no queria que el usuario final tenga acceso al arbol de directorios, ya que lo quiero unicamente para que mis usuarios cifren sus transferencias con mi servidor interno usando el Tunnel SSH del putty, hay forma de evitar que se tenga acceso a la terminal? una configuracion seguramente.


Gracias por todo!

diego.martinez

  • Miembro MUY activo
  • ***
  • Mensajes: 297
    • Ver Perfil
Re: Tunneles SSH
« Respuesta #1 en: Miércoles 21 de Octubre de 2009, 16:17 »
0
buenas:

sigo con el mismo problema, no le ha pasado a nadie mas?

lair

  • Miembro MUY activo
  • ***
  • Mensajes: 213
  • Nacionalidad: mx
    • Ver Perfil
Re: Tunneles SSH
« Respuesta #2 en: Miércoles 21 de Octubre de 2009, 17:03 »
0
Hola.

No se que sistema operativo tienes, pero si es linux lo que puedes hacer para no tener que pelearte con las claves y todo eso, por que no intentas enjaular a los usuarios y que su directorio home se convierta en su directorio raiz. yo nunca he hecho eso, perdon por no poder ayudarte con eso pero si he visto que lo hace.

suerte

su -

  • Moderador
  • ******
  • Mensajes: 2349
    • Ver Perfil
Re: Tunneles SSH
« Respuesta #3 en: Jueves 22 de Octubre de 2009, 02:46 »
0
Suena a un mal timeout, mira los logs del servidor... es lo mejor que podes hacer, ahi te dice si rechazo la conexion (por autenticacion) o si hay algun error.
*******PELIGRO LEE ESTO!!*******

There is no place like 127.0.0.1

Conecto luego existo, no conecto luego insisto.

diego.martinez

  • Miembro MUY activo
  • ***
  • Mensajes: 297
    • Ver Perfil
Re: Tunneles SSH
« Respuesta #4 en: Jueves 22 de Octubre de 2009, 09:40 »
0
buenas:

gracias, por responder.

Lo conseguí resolver, resultaba que en una de las configuraciones estaba escrito que no se abriera una terminal (para evitar que el usuario afectase al server con la consola) y en el otro lado, si no detectaba una terminal, tenia orden de cerrar  :brickwall: asi que solo era un problema de configuración en AMBOS lados  :wacko:

diego.martinez

  • Miembro MUY activo
  • ***
  • Mensajes: 297
    • Ver Perfil
Re: Tunneles SSH
« Respuesta #5 en: Jueves 5 de Noviembre de 2009, 18:58 »
0
buenas:

tengo otro problema con los mismos tuneles ssh.

Cuando entro con mi cuenta de tipo administrador o con la de administrador del equipo, no tengo ningun problema. Todo fino.

ahora bien, cuando entro con una cuenta de usuario local del servidor me da access denied.

Los usuarios estan definidos en el active directory del windows server 2003.
despues en el openssh para windows, hago:

 mkgroup -l >> ..etcgroup
 mkgroup -d >> ..etcgroup

 mkpasswd -l >> ..etcpasswd
 mkpasswd -d >> ..etcpasswd

y con esto deberia de tener disponibles a todos los usuarios del domino y de la cuenta local del sistema.
El windows server no tiene el servidor de dominios activo. Puede ser esto? no deberia no?

alguien sabe a que se puede deber?
mi teoria es que debe de crear algun archivo/directorio para cada usuario en alguna ruta y que se lo deniega por no tener acceso a ese directorio, pero no se a que directorio darle acceso. Le he dado al propio del OpenSSH acceso de control total a todos y tampoco lo resuelve.

ideas?

gracias por anticipado.

diego.martinez

  • Miembro MUY activo
  • ***
  • Mensajes: 297
    • Ver Perfil
Re: Tunneles SSH
« Respuesta #6 en: Lunes 9 de Noviembre de 2009, 17:49 »
0
buenas:

he resuelto el problema, o mas o menos.

Simplemente, el gestor de dominio no estaba bien configurado en el equipo, asi que intentaba usar los usuarios de Active Directory.
Lo he resuelto quitando el servidor de dominio y usando mkgroup -l .

ya investigare lo del dominio, por ahora me vale con esto.

gracias igualmente!  :good: