• Jueves 21 de Octubre de 2021, 15:41

Autor Tema:  Problema Con Arkanoid  (Leído 2002 veces)

Riskz

  • Miembro activo
  • **
  • Mensajes: 39
    • Ver Perfil
Problema Con Arkanoid
« en: Viernes 23 de Mayo de 2008, 02:23 »
0
Bueno ahora estoy intentando hacer un arkanoid... todavia no esta terminado pero si es funcional (aunque falta mejorar algunos aspectos)...

El problema esta en que a veces en un momento dado la pelota se "engancha" a la barra... no me refiero a q quede pegada, sino que ademas de su movimiento normal, se mueve con la barra... Es divertidisimo q pase pero no tendria q pasar... y no encuentro el problema

Dejo el codigo fuente y el programa compilado... si alguien tiene tiempo que pruebe 1-3 veces q seguro pasa

* Por ahora para probar solo hay dos niveles... el segundo termina al destruir 20 bloques no todos (es que me dio vagancia a contarlos jeje)
* La variable ball_type esta en SUPERBALL(1)... esto es para que destruya los muros sin rebotar y probar mas facil el juego. Si quieren testearlo con la pelota comun inicialicenla como BALL(0)

Espero que alguien pueda probarlo, encontrar el fallo y su solucion, o por lo menos decirme si le paso eso que explique

Gracias por adelantado

http://www.2shared.com/file/3326064/92083837/arkanoid.html

Riskz

  • Miembro activo
  • **
  • Mensajes: 39
    • Ver Perfil
Re: Problema Con Arkanoid
« Respuesta #1 en: Viernes 23 de Mayo de 2008, 03:11 »
0
Encontre el problema
ssucedia cuando la pelota iba recta para arriba, el programa interpretaba que estaba quieta, ya que no se movia sobre el eje x...entonces entraba en modo saque, es decir, donde mueves la pelota con la barra y sacas con la barra.

Perdon por haber hecho el post al pedo, es que estuve como 2 horas fijandome (y eso q es poco codigo) y recien cuando hice el post me di cuenta
Saludos y no se si se deberia eliminar el tema o cerrarlo o lo que fuere
=)