• Sábado 22 de Enero de 2022, 09:17

Autor Tema:  Instalar Php5 + Mysql (imposible?)  (Leído 3021 veces)

Altareum

  • Miembro MUY activo
  • ***
  • Mensajes: 327
    • Ver Perfil
    • http://www.avian.com.ar
Instalar Php5 + Mysql (imposible?)
« en: Lunes 27 de Agosto de 2007, 16:53 »
0
Hola gente..... desde ayer que me estoy rompiendo la cabeza con esto.

Tengo instalado apache2, mysql5 y php4. El tema es que tengo que hacer un web con php5 y ahí empezaron los problemas.... Bajé los fuentes de php5, los compilé como simepre, y me tira el suiguiente error:

Código: Text
  1.  
  2. checking for MySQL UNIX socket location... no
  3. configure: error: Cannot find MySQL header files under /var/lib/mysql/.
  4. Note that the MySQL client library is not bundled anymore!
  5.  
  6.  

El configure que use:
Código: Text
  1.  
  2. ./configure  --with-apxs2=/www/apache5/bin/apxs --prefix=/www/php-523 --enable-xml-rpc --with-libxml --with-xmlrpc --with-mysql
  3.  
  4.  

Buscando en internet, encontré de todo, pero nada funcionó. Vi que decían que no hay que usar --with-mysql, pero si lo quito, despues php no tienen las librerías de mysql. Después leí que había que instalar mysql-devel... me tira el mismo error y encima no encuentra un archivo.

También leí que el problema era mysql5, así que instalé el 4 y pasa lo mismo.

La verdad me está volviendo loco.

Alguien puede darme una mano?

Altareum.
El postre!, el postre!, el postre!, el postre!, el postre!, el postre!.....
 | Klinka | Kiree | Avian |

su -

  • Moderador
  • ******
  • Mensajes: 2349
    • Ver Perfil
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #1 en: Lunes 27 de Agosto de 2007, 22:57 »
0
Si lees esto podras ver que existe diferentes paquetes (MySQL-Server, MySQL-Cliet...) Asegurate de tener tanto el cliente como el servidor (si por alguna razon no lo tenes).

Lo mejor que pode hacer es mirar como se installa toodoo esto.
*******PELIGRO LEE ESTO!!*******

There is no place like 127.0.0.1

Conecto luego existo, no conecto luego insisto.

bob esponja

  • Miembro MUY activo
  • ***
  • Mensajes: 411
    • Ver Perfil
    • http://marianoguerra.blogspot.com
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #2 en: Martes 28 de Agosto de 2007, 01:03 »
0
que distro tenes?

Rro_237

  • Miembro activo
  • **
  • Mensajes: 27
    • Ver Perfil
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #3 en: Martes 28 de Agosto de 2007, 06:05 »
0
compadre bajate el wampserver 1.7.1 trae php5, apache 2, mysql5
en softonic.com y lo buscas por wamp

Me avisas como te fue..
saludos!  :whistling:

Altareum

  • Miembro MUY activo
  • ***
  • Mensajes: 327
    • Ver Perfil
    • http://www.avian.com.ar
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #4 en: Martes 28 de Agosto de 2007, 19:37 »
0
Citar
compadre bajate el wampserver 1.7.1 trae php5, apache 2, mysql5

Nop.. la verdad el hecho de pasarme a linux es justamente porque quiero tener el control de la pc, no dejar que los programas haga lo que quieran.
Y justamente uno de los motivos para hacerlo a mano, es poder hacer las configuraciones que quiero y que los archivos de sistema estén donde quiero.

Al final encontré el problema y di con la solución. El problema está en que antiguamente php, para instalarse, usaba archivos que se instalaban con mysql. Los cuales ya no los necesita, de ahí el mensaje que me aparecía:
Note that the MySQL client library is not bundled anymore!

Que traducido sería algo como:
Observe que la biblioteca del cliente de MySQL no está vinculada (?) !

El tema es que igualmente php sigue necesitando las librerías (archivos .h), de mysql para compilarlo, por lo cual, si instalan el rpm (como hice yo), necesitan bajar si o sí el fuente de mysql (cuidado, que sea la misma versión), y linkear en el configure hacia el directorio de la fuente.

Queda algo como:
Código: Text
  1. ./configure .... --with-mysql=/www/install/mysql-5.0.45/
  2.  


Altareum.
El postre!, el postre!, el postre!, el postre!, el postre!, el postre!.....
 | Klinka | Kiree | Avian |

su -

  • Moderador
  • ******
  • Mensajes: 2349
    • Ver Perfil
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #5 en: Martes 28 de Agosto de 2007, 22:34 »
0
Cita de: "Altareum"
Citar
compadre bajate el wampserver 1.7.1 trae php5, apache 2, mysql5

Nop.. la verdad el hecho de pasarme a linux es justamente porque quiero tener el control de la pc, no dejar que los programas haga lo que quieran.
Y justamente uno de los motivos para hacerlo a mano, es poder hacer las configuraciones que quiero y que los archivos de sistema estén donde quiero.

Al final encontré el problema y di con la solución. El problema está en que antiguamente php, para instalarse, usaba archivos que se instalaban con mysql. Los cuales ya no los necesita, de ahí el mensaje que me aparecía:
Note that the MySQL client library is not bundled anymore!

Que traducido sería algo como:
Observe que la biblioteca del cliente de MySQL no está vinculada (?) !

El tema es que igualmente php sigue necesitando las librerías (archivos .h), de mysql para compilarlo, por lo cual, si instalan el rpm (como hice yo), necesitan bajar si o sí el fuente de mysql (cuidado, que sea la misma versión), y linkear en el configure hacia el directorio de la fuente.

Queda algo como:
Código: Text
  1. ./configure .... --with-mysql=/www/install/mysql-5.0.45/
  2.  


Altareum.
Eso es lo que medio dice el link que puse (el primero) no se si lo viste, pero que bueno que ya tengas el problema resuelto  :D
Citar
ompadre bajate el wampserver 1.7.1 trae php5, apache 2, mysql5
en softonic.com y lo buscas por wamp
Ese proyecto se encuentra en sourcefoge.net de hecho es el hosting que usa el desarrollador...
*******PELIGRO LEE ESTO!!*******

There is no place like 127.0.0.1

Conecto luego existo, no conecto luego insisto.

bob esponja

  • Miembro MUY activo
  • ***
  • Mensajes: 411
    • Ver Perfil
    • http://marianoguerra.blogspot.com
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #6 en: Miércoles 29 de Agosto de 2007, 00:44 »
0
cuales son las ventajas de compilarlo si podes instalar los rpm?

ya se algunas ventajas, fui un usuario de gentoo, pero si uno usa una distro rpm based,
entonces tendria sentido instalar los rpms binarios..

Altareum

  • Miembro MUY activo
  • ***
  • Mensajes: 327
    • Ver Perfil
    • http://www.avian.com.ar
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #7 en: Miércoles 29 de Agosto de 2007, 02:48 »
0
Ventajas... varias, sobre todo si quieres usar opciones que no vienen por defecto, o incluir librerías, así como definir carpetas donde se alojarásn los archivos.


Que son justamente varias de las cosas que quiero hacer e instalar.


Altareum.
El postre!, el postre!, el postre!, el postre!, el postre!, el postre!.....
 | Klinka | Kiree | Avian |

zimio

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Re: Instalar Php5 + Mysql (imposible?)
« Respuesta #8 en: Domingo 14 de Octubre de 2007, 04:39 »
0
Cita de: "bob esponja"
cuales son las ventajas de compilarlo si podes instalar los rpm?

ya se algunas ventajas, fui un usuario de gentoo, pero si uno usa una distro rpm based,
entonces tendria sentido instalar los rpms binarios..
Cuando complilas un programa, este queda optimizado para correr en tu hardware.



 :hola:
Hay 11 tipos de personas, las que saben binario, las que no, y las que lo confunden con ternario