• Jueves 9 de Diciembre de 2021, 15:42

Autor Tema:  Problemas En Swf Al Cargarlo En Un Fla  (Leído 1253 veces)

Azulada

  • Nuevo Miembro
  • *
  • Mensajes: 12
    • Ver Perfil
Problemas En Swf Al Cargarlo En Un Fla
« en: Jueves 17 de Mayo de 2007, 16:58 »
0
Buenas!!
A ver si alguien pudiera indicarme un poco...Intentaré explicarme de la manera más clara.
Yo tengo un .fla donde hay un botón y quiero que al presionar el botón cargue un swf.
Yo puse este código en el botón:

on (press){
_root.carga.loadMovie("xx.swf");
}

"carga" es el MC que situé en el escenario y donde el .swf se deberia situar.

Hasta aquí bien, pruebo la película y me carga el swf pero lo carga de una manera raríssima:

- No se escucha el audio que tiene.
- El fondo lo ponde transparente y no blanco como realmente es.
- Va más lento de lo normal ya que el .swf va a 30 fps y el .fla al cual lo importo va a 12 fps (pero no creía que hubiera problema ya que es un swf y deberia ir a su ritmo normal, independientemente de los fps que vaya el .fla donde lo importo) no?
- el swf no respeta su tamaño, es decir, me enseña más animación de la que deberia. El swf tiene un tamaño de 250x250, pero al importarlo es un tamaño más grande (pero no augmenta la mida de los objetos de la animación) sinó que me enseña más animación de la que enseña realmente el swf sin ser importado!!!!!

No entiendo nada.... :think:
Teneis alguna idea??Será de gran ayuda

dragnus

  • Miembro MUY activo
  • ***
  • Mensajes: 103
  • Nacionalidad: co
    • Ver Perfil
    • http://www.panalcorp.com
Re: Problemas En Swf Al Cargarlo En Un Fla
« Respuesta #1 en: Domingo 17 de Junio de 2007, 01:58 »
0
puede q sea un poco tarde..pero podrias subie el fla,, y ver q pasa ??