• Lunes 21 de Junio de 2021, 02:00

Autor Tema:  Error Con Crystal Report  (Leído 2684 veces)

see07

  • Miembro activo
  • **
  • Mensajes: 51
    • Ver Perfil
Error Con Crystal Report
« en: Miércoles 16 de Febrero de 2005, 20:38 »
0
Hola:
Tengo un proyecto en C#, el cual contiene una  web form, la cual tiene un botón que llama a una  web page que contiene un  crystalreportviewer, el cual  containe a reporte de CrystalReport. Estoy llamando a está página a través de Response.Redirect("WebForm2.aspx"); WebForm2 no se abre, sinó que envía este error: [Null]Reference Exception: Referencia a objecto no establecida como instancia de un objeto.]
¿Alguien sabe cual es la causa de este error?
Gracias anticipadamente por su ayuda.
A.L.

Güorker

  • Miembro MUY activo
  • ***
  • Mensajes: 383
    • Ver Perfil
Re: Error Con Crystal Report
« Respuesta #1 en: Jueves 17 de Febrero de 2005, 10:24 »
0
Hola,

Ese error suele ocurrir cuando intentas hacer alguna operación con un objeto que está a null.

Si  en el error te pone la pagina y linea donde se produce el error, ya sabras que objeto es el que está a null.

Para asegurarte, pon un breakPoint en esa línea con el Visual Studio e inspeccionando los objetos que aparezcan en esa línea de codigó podrás concretar cual es el que está a null.

Como solucionarlo... ese es otro tema, ya que solo tu conoces el codigo. Pero decir que todos los objetos deben de inicializarse antes de utilizarlos.

Suerte y Saludos
[size=109]Ondo ibili, gutxi gastau eta bueltak amari[/size]
[size=109]Pasalo bien, gasta poco y las vueltas a tu madre[/size]

see07

  • Miembro activo
  • **
  • Mensajes: 51
    • Ver Perfil
Re: Error Con Crystal Report
« Respuesta #2 en: Jueves 17 de Febrero de 2005, 16:46 »
0
Gracias amigo Guorker.
Lo curioso del caso es que el error se produce al llamar la webform, no entra ni al primer break point que pongo en page load.
Estoy desconcertado.
 :whistling:

Güorker

  • Miembro MUY activo
  • ***
  • Mensajes: 383
    • Ver Perfil
Re: Error Con Crystal Report
« Respuesta #3 en: Jueves 17 de Febrero de 2005, 17:46 »
0
Hola de nuevo,

A mi tambien me deja asombrado eso que dices. Nunca me había ocurrido algo así.

Lo unico que se me ocurre es que no se pueda cargar el codebehind (el archivo cs) de la pagina. Puede ser que el aspx y el cs se llamen de distinta forma, o que en la 1ª linea del HTML de la pagina aspx mo esté bien declarado el codebehind.

Y si no es eso, no se, puede ser algo relacionado con lo de Cristal.

Yo nunca he usado Cristal o Crystal o como se escriba, así que me temo que no tengo más ideas.

Suerte con tu problema.

Saludos.

PD: No olvides escribir la solución cuando la obtengas.  ;)
[size=109]Ondo ibili, gutxi gastau eta bueltak amari[/size]
[size=109]Pasalo bien, gasta poco y las vueltas a tu madre[/size]

see07

  • Miembro activo
  • **
  • Mensajes: 51
    • Ver Perfil
Re: Error Con Crystal Report
« Respuesta #4 en: Lunes 21 de Febrero de 2005, 16:42 »
0
Hola:
Finalmente resolví esto reinstalando visual studio .NET, algo había erróneo alli.
Saludos.
A.L. :whistling: