• Martes 17 de Enero de 2017, 20:11

Autor Tema: [Código Fuente] pseudocodigos  (Leído 5257 veces)

galicia.323

  • Nuevo Miembro
  • *
  • Mensajes: 1
    • Ver Perfil
[Código Fuente] pseudocodigos
« en: Jueves 3 de Mayo de 2012, 03:48 »
0

Publicidad 
hola chavos esta es mi primera publicacion y espero que les ayude en algo y comente :rain:

Proceso numero primo
   Escribir "ingrsar el numero"
   Leer x
   si x = 1 Entonces
      Escribir "El numero es primo"
   Sino
      a<-0
   FinSi
   
      Para i<-1 Hasta x Hacer
         si x mod i = 0 Entonces
            a<-a+1      
         FinSi
      finpara
      si a = 2 Entonces
         
         Escribir "El numero es primo"
      Sino
         Escribir "El numero no es Primo"
      FinSi
      
FinProceso :lightsabre:



sik2986

  • Nuevo Miembro
  • *
  • Mensajes: 1
    • Ver Perfil
Re:pseudocodigos
« Respuesta #1 en: Sábado 19 de Mayo de 2012, 09:23 »
0
Tengo que decirte que el número 1 no es considerado un número primo, solo un "número simple", debido a que un número primo tiene como característica tener "solo dos divisores" (que en la práctica son ellos mismos y la unidad). Por el resto tu algoritmo está muy bien  :yes:

Proceso numero_primo
   Escribir "ingresar el numero"
   Leer x
      a<-0
      Para i<-1 Hasta x Hacer
         si x mod i = 0 Entonces
            a<-a+1     
         FinSi
      finpara
      si a = 2 Entonces
         Escribir "El numero es primo"
      Sino
         Escribir "El numero no es Primo"
      FinSi
FinProceso