• Miércoles 29 de Marzo de 2017, 15:13

Autor Tema: [Código Fuente] Software de Control de Acceso de Personal  (Leído 32752 veces)

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
[Código Fuente] lo verifique
« Respuesta #25 en: Miércoles 13 de Febrero de 2008, 04:35 »
0

Publicidad 

Segun yo misma, esta correcto el formato.

RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
Error
« Respuesta #26 en: Miércoles 13 de Febrero de 2008, 12:50 »
0
Te saco ese error por que no hay registros en la tabla tbentradas_personal, 'tons no puede leer la cédula que es el número que está intentando consultar, por lo de los mails, solo es cambiar los que hay predeterminados en el archivo mail_html.php y listo
El pasado son solo recuerdos, el futuro son solo sueños

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
ok
« Respuesta #27 en: Miércoles 13 de Febrero de 2008, 20:53 »
0

Entonces debo insertar datos en:
tbentradas_personal en los campos:
id
nombre
cedula
tipo....... a que se refiere con tipo?

y en tabla tbentradas_bitacora estan los campos:

id
id_personal

imagino que id_personal es el id relacionado con la otra base de datos.¿? cierto?

saludos

RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
Registros
« Respuesta #28 en: Miércoles 13 de Febrero de 2008, 22:13 »
0
Por el campo tipo de tbentradas_personal no te preocupes en este puedes colocar '0', la tabla tbentradas_bitacora se llena automáticamente con el ingreso de los datos por la aplicación.
El pasado son solo recuerdos, el futuro son solo sueños

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
LISTO
« Respuesta #29 en: Miércoles 13 de Febrero de 2008, 23:58 »
0


Ya quedo la primer prueba, ingrese un registro a tbentradas_personal.

Ahora despues de ingresarlo me sale este comentario:
       Nombre del empleado
SU ENTRADA SE HA REGISTRADO A LAS 16:55:56 GRACIAS

La aplicacion ahi  se queda?  no deberia regresar al reloj?


RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
Claro
« Respuesta #30 en: Jueves 14 de Febrero de 2008, 12:41 »
0
Como pasaste a un nuevo archivo la parte del php debes hacer un regreso al index.php, hazlo así:
echo "<script languaje='javascript'>parent.location=('./index.php');</script>";
El pasado son solo recuerdos, el futuro son solo sueños

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
DONDE?
« Respuesta #31 en: Jueves 14 de Febrero de 2008, 19:48 »
0


En mi archivo TEXT.PHP
lo pongo fuera del codigo PHP o dentro?

<?PHP
¿dentro?
?>

RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
Dentro
« Respuesta #32 en: Jueves 14 de Febrero de 2008, 19:54 »
0
dentro del<?php echo "<script languaje='javascript'>parent.location=('./index.php');</script>"; ?>
El pasado son solo recuerdos, el futuro son solo sueños

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
bien
« Respuesta #33 en: Jueves 14 de Febrero de 2008, 20:02 »
0

Es dentro ya  lo hice.

Pero al dar click en guardar hace el cambio de pantalla demasiado rapido.

else
    {
      $query_actualiza = "UPDATE tbentradas_bitacora SET hora_salida='".$hora."' WHERE id_personal=".$id_user."
                          AND fecha LIKE '".$fecha."' AND id=".$ulti;
      echo "<div align='center'><b>".$nombre."</b><br>SU SALIDA SE HA REGISTRADO A LAS ".$hora." GRACIAS</div>";
      $result_actualiza = mysql_query($query_actualiza) or die(mysql_error());
      $query_update = "UPDATE tbentradas_personal SET yavinonota=0 WHERE id=".$id_user;
      $result_update = mysql_query($query_update) or die(mysql_error());
    }
  }
  echo "<script languaje='javascript'>parent.location=('./index.php');</script>";

"por cierto no llegan las consultas a los emails"
tendria que deshabilitar algun firewall??


RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
2 cosas
« Respuesta #34 en: Jueves 14 de Febrero de 2008, 20:09 »
0
1) Como ya todo mola bien, vuelve a colocar todo lo de texto.php en el index.php y en la cadena action deja:
action="$_SERVER['PHP_SELF']"

2) A mi me funciona lo de los mail, por que mi servidor de correo esta directo y la IP del servidor lo tengo configurado en el php.ini
El pasado son solo recuerdos, el futuro son solo sueños

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
Correcto
« Respuesta #35 en: Jueves 14 de Febrero de 2008, 20:54 »
0

La primer opcion ya quedo :) gracias.

La segunda no entiendo.
Si yo quiero que esas consultas me lleguen a un correo gratuito (gmail, hotmail, yahoo etc)
no sera posible?


cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
configure
« Respuesta #36 en: Viernes 15 de Febrero de 2008, 21:44 »
0

Configure php.ini
[mail function]
; For Win32 only.
SMTP = nombre de mi servidor
smtp_port = 25


no manda el email

RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
SMTP
« Respuesta #37 en: Viernes 15 de Febrero de 2008, 22:01 »
0
Prueba con algún SMTP gratuito que te permita enviar mails sin confirmación ni nada por el estilo, esto si ya queda a cosa tuya, en otro caso lo que puedes hacer es en vez de enviar por mail, puedes imprimir esos valores en pantalla y listo.
El pasado son solo recuerdos, el futuro son solo sueños

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
de acuerdo
« Respuesta #38 en: Sábado 16 de Febrero de 2008, 00:19 »
0

Checare con el SMTP gratuito.


y estare checando lo de imprimir en pantalla también. Que funciones de PHP, me permiten hacer eso?

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
probando
« Respuesta #39 en: Sábado 16 de Febrero de 2008, 01:06 »
0


Pues no me mola con eso de los emails

No se si me haga falta configurar algo en mail_html.php o en php.ini

Ya tengo un servidor gratuito SMTP y no me llega nada




RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
Respuesta
« Respuesta #40 en: Sábado 16 de Febrero de 2008, 13:06 »
0
1) Coje la impresión que está enviando al mail y en vez de decirle mande a mail (:P Valga la redundancia) dile que imprima esos datos en pantalla, es solo cuestión de enviar esos datos a pantalla.

2) No sé, ahí si me dejas sin explicaciones, como te digo acá donde lo monté en el php.ini yo coloco directamente el servidor mail de la empresa y me mola bien.
El pasado son solo recuerdos, el futuro son solo sueños

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
vaya
« Respuesta #41 en: Domingo 17 de Febrero de 2008, 00:53 »
0


Ya esta.

Gracias por tu ayuda
Y buena aplicación, le hare a mi modo y te comento, vale?

saludos

cybergatita

  • Miembro MUY activo
  • ***
  • Mensajes: 154
    • Ver Perfil
Una pregunta
« Respuesta #42 en: Martes 26 de Febrero de 2008, 19:06 »
0

RadicalEd:

Que servidor SMTP estas usando? el de windows?

RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
SMTP
« Respuesta #43 en: Martes 26 de Febrero de 2008, 19:10 »
0
No, es un servidor linux que hay en la empresa.
El pasado son solo recuerdos, el futuro son solo sueños

victorhugo_cb

  • Nuevo Miembro
  • *
  • Mensajes: 1
    • Ver Perfil
NUEVAMENTE EL CODIGO
« Respuesta #44 en: Viernes 21 de Marzo de 2008, 18:19 »
0
MI FRIEND, ENVIA NUEVAMENTE EL CODIGO CON TODOS LOS CAMBIOS QUE HICISTE POR FAVOR......

JrcsDev

  • Miembro MUY activo
  • ***
  • Mensajes: 245
  • Nacionalidad: ve
    • Ver Perfil
    • http://codigo7.wordpress.com/
Solución a uno de los errores...
« Respuesta #45 en: Martes 6 de Mayo de 2008, 20:36 »
0
con respecto al error que se trató de corregir quedando un archivo texto.php, yo lo solucioné de la siguiente forma:

cambia el: action="<?$_SERVER['PHP_SELF']?>"

por: action="<?php echo $_SERVER['PHP_SELF']?>"


y tambien: action="<?$_SERVER['texto.php']?>"

por: action="<?php echo $_SERVER['texto.php']?>"

en fin, se trata de colocar siempre "php" en las etiquetas de apertura de código, porque no sabemos si la configuración del servidor permite colocar solo <? ?>... yo uso wamp, y me había dado el mismo error, solo coloqué <?php ?> y así me funcionó... bueno, aun no pruebo lo de la lectora porque no tengo una... pero seguiré revisando el código...
Sígueme en Twitter]
Donar comida a los chicos necesitados!
Todo lo puedo en Cristo que me fortalece...

F_Tanori

  • Moderador
  • ******
  • Mensajes: 1911
  • Nacionalidad: mx
    • Ver Perfil
    • http://www.ingenieria-soporte.com
Software de Control de Acceso de Personal
« Respuesta #46 en: Martes 17 de Junio de 2008, 22:40 »
0
Para que funcione el primer metodo es necesario que este configurada la directiva

short_tags_open=on

en el php ini

Saludos



" ExIsTo y A vEcEs PiEnSo "

NOTA:
===========================================================================================================================
Este foro es para ayudar, aprender, compartir... usenlo para eso,
NO SE RESUELVEN DUDAS POR MENSAJE PRIVADO Y MENOS POR CORREO
===========================================================================================================================

dajacar

  • Nuevo Miembro
  • *
  • Mensajes: 10
    • Ver Perfil
hola
« Respuesta #47 en: Martes 9 de Septiembre de 2008, 16:58 »
0
hola amigo me gustaria poderte contactar  quiero hacere unas preguntas  porfa agregame  dajacar@hotmail.com

RadicalEd

  • Moderador
  • ******
  • Mensajes: 2428
  • Nacionalidad: co
    • Ver Perfil
Hola
« Respuesta #48 en: Martes 9 de Septiembre de 2008, 17:27 »
0
dilo por acá!!!
El pasado son solo recuerdos, el futuro son solo sueños

darwin1979

  • Nuevo Miembro
  • *
  • Mensajes: 2
    • Ver Perfil
REQUIERO
« Respuesta #49 en: Jueves 23 de Octubre de 2008, 18:57 »
0
SDFSDFDSF