• Jueves 23 de Octubre de 2014, 18:31

Autor Tema:  [VB]La biblioteca de objetos no está registrada  (Leído 4906 veces)

Matute!

  • Nuevo Miembro
  • *
  • Mensajes: 2
    • Ver Perfil
[VB]La biblioteca de objetos no está registrada
« en: Jueves 24 de Julio de 2008, 01:32 »
0

Publicidad 
Hola!, ya es la segunda ves que me pasa esto, tube probando las mil y una posibles soluciones y no lo puedo solucinar...

Cuando cargo un proyecto (por ejemplo AO) me tira error "La biblioteca de objetos no está registrada", pongo aceptar, y me dice "Errores al cargar".. Bueno, finalmente carga, por lo visto mal...

Los módulos los puedo abrir, pero al intentar abrir un FORMULARIO y al COMPILAR me tira el error de "No enviar"...

Con respecto al mensaje que marqué con color rojo, intenté ponerlo desde componentes, pero al buscarlo, seleccionarlo y poner aceptar, me manda el mismo error
Cuando me manda el mensaje de "no enviar" se cierra, y cuando hago doble click en el form lo mismo...

Ya lo reinstalé, pero nada..

El año pasado me pasó lo mismo.. Pero como no encontré solución tube que formatear la pc para que me vuelva a andar..

Alguna idea?

cpmario

  • Miembro HIPER activo
  • ****
  • Mensajes: 629
    • Ver Perfil
    • http://www.cpimario.com
Re: [VB]La biblioteca de objetos no está registrada
« Respuesta #1 en: Jueves 24 de Julio de 2008, 18:05 »
0
No ha habido respuestas a tu pregunta, la causa probable es que estás haciendo mal la pregunta.
En parte es porque estás abreviando y dando por hecho que sabemos de que se trata, en todas estás cosas: (por ejemplo AO), "Errores al cargar"..., "No enviar"...

También hace falta saber de que se trata tu proyecto, que controles usa, si tiene controles personalizados, que referencias tiene, es para una base de datos DAO o ADO.
El VB6 tiene el service pack 6?.
 <_<

cpmario

  • Miembro HIPER activo
  • ****
  • Mensajes: 629
    • Ver Perfil
    • http://www.cpimario.com
Re: [VB]La biblioteca de objetos no está registrada
« Respuesta #2 en: Jueves 24 de Julio de 2008, 18:53 »
0
He estado revisando la web para poder ayudarte, me he encontrado que has puesto este post en muchos lugares, con más datos, que los que pusiste aquí.
He buscado en Google con la frase en inglés "Object library not registered" ya que siempre son en mayor cantidad la respuestas a este tipo de problemas raros.

Lo mejor que puedo recomendarte es que revises esta página:

http://support.microsoft.com/?scid=kb%3 ... 0&x=16&y=9

Y descargues una versión más nueva del MDAC en esta página:

http://msdn.microsoft.com/en-us/data/aa937729.aspx

Descarga la tercera opción MDAC 2.8, ya que MDAC 2.8 SP1 no es compatible con XP.

Recuerda que tienes que cambiar las referencias en el proyecto a la versión 2.8.
 :comp:

Matute!

  • Nuevo Miembro
  • *
  • Mensajes: 2
    • Ver Perfil
Re: [VB]La biblioteca de objetos no está registrada
« Respuesta #3 en: Jueves 24 de Julio de 2008, 19:30 »
0
Ok, muchas gracias..

Pasa que no puedo dejar enlaces :(..

Ahora pruebo y te contesto.